Popüler bir NPM paketinde, kötü amaçlı kodlar keşfedildi

Çok popüler bir JavaScript NPM kütüphanesini olan  ” UAParser.js “ın saldırıya uğrayıp, bazı kaynak kodlarının kötü amaçlı kodlar ile değiştirildi. ABD Siber Güvenlik ve Altyapı Güvenliği Ajansı tarafından da kullanıcılar ve şirketler için bir uyarı yayınlandı. Bununla birlikte Github‘ın güvenlik ekibide kullanıcılar için bir uyarı yayınladı.

Olay ilk olarak UAParser.js’nin geliştiricisi Faisal Salman tarafından duyuruldu. Salman, birinin NPM hesabını ele geçirdiğini ve muhtemelen kötü amaçlı yazılım yüklenmiş bazı güvenliği ihlal edilmiş paketler (0.7.29, 0.8.0, 1.0.0) yayınladığına inandığını belrtmiş. Salman, saldırıyı keşfettikten belli bir süre sonra kullanıcıların etkilenmemesi adına güvenliği ihlal edilmiş kütüphane sürümlerini kaldırıp, güncel olan sürümlerini yayınlamış.

UAParser.js kütüphanesi aralarında Facebook, Apple, Amazon, Microsoft, IBM gibi teknoloji devlerinin yanı sıra pek çok şirket tarafındanda kullanılıyor. Kütüphanenin her hafta 6-7 milyon arası bir indirilme sayısına sahip olduğu belirtiliyor.

Güvenliği ihlal edilmiş sürümler: 0.7.29, 0.8.0, 1.0.0
Güncellemesi yayınlanan sürümler: 0.7.30, 0.8.1, 1.0.1

Önceki Yazı

Emsisoft, BlackMatter fidye yazılımı kurbanları için şifre çözücü yayınladı

Sonraki Yazı

Macaristan’da üst düzey bir terörle mücadele yetkilisi, Pegasus casus yazılımının hedefi oldu

İlgili İçerikler